Jump to content


BG1 - few questions

8 replies to this topic

#1 zen84

  • Members
  • 3 posts

Posted 24 March 2012 - 06:02 AM


I have 0.7.0 version of gemRB and have few problems. I don't know if those are bugs/glitches or I just don't know how to set something correctly,

1. Game settings do not save, everytime time I launch game I have to set them again.
2. I switched off 'relative mouse cursor', prefere point and click, but can't move the map UP using screen. Going down/left/right works fine. I have trackball, so I can work it around, but still, it is much easir moving around map using screen.
3. Double clik on portrait doesn't always focus on char, mostly, doesn't work in pause mode.
4. Is there a way to set gemRB to prevent screen from going OFF, as I have 30sec setting and I do not want to change it everytime I play.
5. How to get Branwen, can't target her
6. When I lvl up, I can't get max HP points, lvled up with Imoen, couldn't get more than 6 points, now I lvled up with my dwarf warrior (19 con) and 10 points is max I can get (tried like 100 times) - is there something wrong with it or I just have really big bad luck??

#2 SyntaxError

  • Members
  • 876 posts

Posted 24 March 2012 - 08:41 AM

#1 is unimplemented. probably will be in the coming months since so many people bring it up :)

#2 and 4 would be android wrapper specific issues and that is neither developed nor maintained by us.

#3 maybe android too except maybe not working when paused. ill bet thats a simple fix.

#5 no idea who branwen is. i dont see how this is possible tho

#6 I doubt you have luck that bad since you were actually able to get gemrb running on android :p however, i have no idea what max HP should be so i cannot comment.

#3 Avenger

  • Modders
  • 3428 posts
  • Gender:Male
  • Location:Hungary

Posted 24 March 2012 - 09:06 AM

Branwen is the petrified character in the circus. Petrified/frozen characters should be valid spell targets.

Hmm, actually, this works for me, at least using scrlpet.itm

Edited by Avenger, 24 March 2012 - 09:19 AM.

#4 alx3apps

  • Members
  • 126 posts

Posted 24 March 2012 - 11:14 PM

About android issues
#2 - you can use
option in GemRB.cfg to have scroll areas.
#4 - not sure about that, never had this problem, but I've always used 10 min timeout. I'll try it.

Also FYI - latest android builds are here - http://sourceforge.n...naries/android/ , some game problems were fixed since 0.7.0.

edit: yes, #4 is not implemented, I'll try to add wakelock for the next SF build, it would requre additional permission though.

Edited by alx3apps, 24 March 2012 - 11:36 PM.

#5 lynx

  • Modders
  • 1871 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 25 March 2012 - 12:00 AM

re 6: check the ingame hp (out of the records screen), since the label there may have not been updated for the constitution bonus.

GemRB - IE anywhere.
Mages needed! Python tamers needed for iwd2!

Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored!

#6 alx3apps

  • Members
  • 126 posts

Posted 25 March 2012 - 02:00 AM


Concerning #4 - try this build http://www.mediafire...9hc3p2tc15wasg8 , it's going to appear on SF soon.

Note, on every update you must update "override" directory and replace "GUIScript" directory with new one.
You have two alternatives for that:
- unpack APK file as ZIP archive, get these dirs from assets dir and replace GUIScripts and overwrite "override" manually
- delete "libsdl-DownloadFinished-1.flag" and "libsdl-DownloadFinished-2.flag" files and enable both GUIScripts and override in "downloads" SDL menu - you'll see download process on first start.

This can be automated, but it hasn't done yet.

#7 zen84

  • Members
  • 3 posts

Posted 25 March 2012 - 02:05 AM

#3 checked it once again, if pause is on, you can't focus on char with double click on portrait. if you double click, switch off pause it will focus, but not as long as pause is on
#5 still can't target her, had to copy saves to pc, so I have her on team now ;p
#6 seems to be like lynx said

#8 Avenger

  • Modders
  • 3428 posts
  • Gender:Male
  • Location:Hungary

Posted 25 March 2012 - 03:00 AM

With what did you try to target Branwen? I'm sure our current engine works with scrlpet.

#9 zen84

  • Members
  • 3 posts

Posted 26 March 2012 - 12:43 AM

Stone to flesh scroll bought at Beregost temple. Also tried with the scroll from that guy near Branwen. Tried again, but no luck

Reply to this topic


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users