Jump to content


Photo

iOS port of GemRB (iPad/iPhone)

iOS iPad iPhone GemRB

197 replies to this topic

#1 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 02 February 2012 - 07:32 AM

Most information regarding Download and installation can be found on the wiki.

For your convenience here are helpful some direct links to helpful information:Please check the wiki known issues and bugs before posting a problem. If you prefer you may submit a bug ticket on source forge. Try to only post iOS specific bugs and issues here. If you aren't sure please test (if you can) with GemRB on another platform (try to use the same Buildbot version)

There is currently no stable release for iOS; only Buildbot incremental builds are available until next GemRB release.

For reference the old thread is here.

#2 antnbuckley

antnbuckley
  • Members
  • 7 posts

Posted 02 February 2012 - 11:04 AM

hi all, hope you can offer some assistance

to begin i'm using version 208 of gemrb

baldurs gate 2 is loading and starting with no problems. i'm just having a crash issue after using the portal and meeting up with yoshimo. when i go in the next room and try to destroy the cages i'm having constant crash issues then. it seems to be having problems searching for firimp.bam


https://rapidshare.c...15210/GemRB.log


thanks in advance

#3 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 02 February 2012 - 11:26 AM

I'm not really interested in waiting 5 min to download a log so ill just take a guess based on what you have said that you ought to set a cd path in the config. where you should set that to depends on where you obtained BG2.

the cd path problems are a known issue (with gemrb in general) and will be fixed sometime before 0.7.1 or whatever the stable release will be called.

#4 antnbuckley

antnbuckley
  • Members
  • 7 posts

Posted 02 February 2012 - 12:24 PM

I'm not really interested in waiting 5 min to download a log so ill just take a guess based on what you have said that you ought to set a cd path in the config. where you should set that to depends on where you obtained BG2.

the cd path problems are a known issue (with gemrb in general) and will be fixed sometime before 0.7.1 or whatever the stable release will be called.


perfect i'll try that and see what happens

thanks

#5 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 02 February 2012 - 05:10 PM

you can be certain this is the problem if intro movies dont play. if they do play then maybe i should look at the log, but in the future it would be nice if you could post to pastebin or something more friendly.

#6 antnbuckley

antnbuckley
  • Members
  • 7 posts

Posted 02 February 2012 - 06:13 PM

you can be certain this is the problem if intro movies dont play. if they do play then maybe i should look at the log, but in the future it would be nice if you could post to pastebin or something more friendly.


ok i will do. point taken :)

the into movies do play. and i set the cd path in the config.

i'll re post the log tomorrow with pastebin.

#7 iain_benson

iain_benson
  • Members
  • 4 posts

Posted 03 February 2012 - 02:40 AM

i guess i have never tested running at a resolution other than 1024x768. of course the best thing to do is install the widescreen mod, but this should really be fixed. I don't know if its an SDL bug or not, but it sounds like its something i could work out in the touch code regardless. I'm a bit stumped that regular clicks wouldn't have the same offset tho. I see now why single mouse buttons arent affected. Its because touch events are screen-wide and mouse events are scaled to the SDL surface.

Edit: this problem has been fixed in source.


I've downloaded and installed v0.7.0-224 and it appears to have fixed the problem, though the launcher has become somewhat unstable; it seems to just crash out most of the time. The crash log can be found at http://pastebin.com/xZ9LXHF9

Build 209 appears to work reliably every time, but 213 doesn't which suggests it was one of the GEM_AppDelegate fixes or the merge of the master branch which is causing the issue.


Also, I just figured out why Icewind Dale was leaving the status bar on display - it seems that GemRB ignores the fullscreen switch in the cfg file, and instead uses the one in the icewind.ini file, which was set to 0, so it was trying to run it in a window, even though the cfg file said to not run it in a window!

Edited by iain_benson, 03 February 2012 - 04:01 AM.


#8 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 03 February 2012 - 07:06 AM

commits labeled as "merged brach whatever" just mean that I committed locally while there were upstream changes ahead of my master.

Looking at the crash log i cant say a whole bunch since apparently GemRB symbols are still being stripped, but if you are sure of the build number i can symbolicate.

Also is there any way you could provide a run log from the crash? Cocoa is real good about logging things. If you could indicate anything that you are doing to induce the crashing it would also be helpful.

It probably wasn't one of the fixes causing the crash so much as exposing something i did wrong a long time ago. I think now that I'm dropping back to the main runloop prior to launching the game is causing some autoreleased object to become deallocated (which was one of my intended side effects) I simply need to retain whatever object is needed and release it when im done with it.

Edited by SyntaxError, 03 February 2012 - 07:07 AM.


#9 antnbuckley

antnbuckley
  • Members
  • 7 posts

Posted 03 February 2012 - 08:44 AM

http://pastebin.com/9Dw5y85N

here's my log as promised

i think thats worked. no idea how to do the embed thing

Edited by antnbuckley, 03 February 2012 - 08:47 AM.


#10 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 03 February 2012 - 09:57 AM

http://pastebin.com/9Dw5y85N

here's my log as promised

i think thats worked. no idea how to do the embed thing


I see nothing wrong in that log (all the "errors" are benign)

can you provide a crash report from the latest gemrb for iOS and/or a save game with directions on how to trigger the crash?

lynx was able to reproduce.

Edited by SyntaxError, 03 February 2012 - 10:04 AM.


#11 antnbuckley

antnbuckley
  • Members
  • 7 posts

Posted 03 February 2012 - 10:08 AM


http://pastebin.com/9Dw5y85N

here's my log as promised

i think thats worked. no idea how to do the embed thing


I see nothing wrong in that log (all the "errors" are benign)

can you provide a crash report from the latest gemrb for iOS and/or a save game with directions on how to trigger the crash?

lynx was able to reproduce.


thanks guys

just shout if you need me to post anything more

#12 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 03 February 2012 - 10:53 AM

no need. lynx has fixed the issue.

#13 iain_benson

iain_benson
  • Members
  • 4 posts

Posted 03 February 2012 - 02:47 PM

Looking at the crash log i cant say a whole bunch since apparently GemRB symbols are still being stripped, but if you are sure of the build number i can symbolicate.

Also is there any way you could provide a run log from the crash? Cocoa is real good about logging things. If you could indicate anything that you are doing to induce the crashing it would also be helpful.


I'm definitely sure of the version numbers: 209 works fine every time, 213 crashes almost every time.

I don't have any copies of the run log I'm afraid, my iPad is downstairs with 209 on it, and my baby is on my lap drinking his bottle, so I can't produce one easily right now, but all it contained when I did generate one was two lines: one (I think the 2nd line) stated which cfg file it was using, and I can't remember what the other line was.

To reproduce the error, all I needed to do was select a cfg file and press the play button. 99% of the time it would immediately drop straight out to the springboard.

#14 SyntaxError

SyntaxError
  • Members
  • 877 posts

Posted 03 February 2012 - 03:22 PM

i cant reproduce this. maybe you should try the latest build.

Edited by SyntaxError, 03 February 2012 - 03:22 PM.


#15 iain_benson

iain_benson
  • Members
  • 4 posts

Posted 04 February 2012 - 01:27 AM

Yep, it appears to be fixed in 229

Cheers
Iain



Reply to this topic



  



Also tagged with one or more of these keywords: iOS, iPad, iPhone, GemRB

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users