Jump to content


Photo

Icewind Dale 2 Fullscreen problems (ATI 5970).

ATI Radeon HD Windows 7 5970 Icewind Dale 2 Infinity Engine

5 replies to this topic

#1 SenhorSick

SenhorSick
  • Members
  • 4 posts

Posted 03 January 2012 - 02:45 PM

Hey all,

Ok so I've searched everywhere and all posts are either a couple of years old or fixes for Nvidia or older ATI cards so sorry if this has already been posted here but I really couldn't find a fix specific to recent hardware and or software I and others with similar problems may be using.

Anyways the problem is:

Flickering and mouse icon ghosting at any widescreen resolution above the supported 1024x768. Running Icewind Dale 2 GOG version.

I'm using Windows 7 64bit and a ATI Radeon HD5970 4GB edition.

Turning on AA 16X helps reduce the screen flickering but then seems to make the game feel sluggish.

I've tried various fixes posted across the web and messed around with the CCC settings but still no luck.

Any ideas or fixes already in existence?

Cheers!

#2 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Members
  • 3919 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 04 January 2012 - 04:53 AM

Try all the resolution options you have between the 800x600 and 2560x2048 that your monitor can display and figure what makes your eyes bleed the least ... it's monitor model based in IwD 2. Here's my Config.exe's Graphic setting before the Widescreen mod is installed:

Posted Image

Edited by Jarno Mikkola, 04 January 2012 - 04:54 AM.

Yes... I am probably still editing the post above.
FAQ for the Megamods. Frequently Answered Questions.

It should be ready after dinner yes. :)

Quoted for Demivrgvs 5000th post.

#3 SenhorSick

SenhorSick
  • Members
  • 4 posts

Posted 04 January 2012 - 12:35 PM

By monitor model based do you mean it will run well or not according to which monitor I'm using?

I was running it on my laptop at 1366x768 with the widescreen mod and it ran fine. I'm thinking it might have more to do with GPU settings? I read in a lot of threads that turning off triple buffering and catalyst A.I worked well for some people. Would you know of any other settings that might be affecting performance? My monitor is currently running on 1680x1050 and I've tried all other 16:10 and other resolutions.

Thanks

#4 SenhorSick

SenhorSick
  • Members
  • 4 posts

Posted 04 January 2012 - 01:41 PM

Fixed using dazzle's suggestion over at shsforums.net

Hi all,

I managed to fix this problem for baldur's gate in vista by enabling software directdraw. Maybe it also works in XP and for other infinity engine games, I haven't tried. It'll only work for the 2d rendering engine (OpenGL mode won't work). After you've applied the fix, the game is very fast and without any artifacts. The fix is permanent. You don't need loader scripts or stuff like that.

Here's how to:
1. Download and install the microsoft application compatiblity toolkit:
http://www.microsoft...;displaylang=en
2. Start the 'Compatibility Administrator' with administrator rights.
3. Click the 'New' Button
4. Right click the new database. Select 'Create new application fix...'
5. Name your program and vendor however you like. Browse to your bgmain2.exe file. Click next
6. Select 'None' for operating system modes. Don't select additional compatibility modes. Click next
7. Tick the 'ForceDirectDrawEmulation' compatibility fix.
8. Click next and finish.
9. Save your database.
10. Right click the database and select install. This will install the database.
11. Close the compatibility administrator and start baldur's gate. It should work correctly in 32bit mode without any ingame rendering fixes. You don't need to run the compatibility administrator again.


Thanks!

P.S. The game is running a little faster than usual using the compatibility toolkit other than that it works perfectly. Is there anything I can edit to correct this?

#5 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Members
  • 3919 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 04 January 2012 - 02:51 PM

P.S. The game is running a little faster than usual using the compatibility toolkit other than that it works perfectly. Is there anything I can edit to correct this?

Well, there is the max Frames Per Second count that can be edited in the Icewind.ini file, it should be 30...

Maximum Frame Rate=30

Yes... I am probably still editing the post above.
FAQ for the Megamods. Frequently Answered Questions.

It should be ready after dinner yes. :)

Quoted for Demivrgvs 5000th post.

#6 SenhorSick

SenhorSick
  • Members
  • 4 posts

Posted 05 January 2012 - 03:10 PM

Thanks mate but changing the frame rate hasn't affected anything. Is there anything else that could be edited to slow down game speed? It is still playable though and if it wasn't for the voiced NPCs speaking too fast I wouldn't mind it at all.



Reply to this topic



  



Also tagged with one or more of these keywords: ATI, Radeon, HD, Windows 7, 5970, Icewind Dale 2, Infinity Engine

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users