Jump to content


Photo

Version 20 comments/bug reports


42 replies to this topic

#16 Anduin Shadow Mantle

Anduin Shadow Mantle
  • Members
  • 3 posts

Posted 25 January 2012 - 09:24 AM

Hi!

First what super Mod! :D

Secondly a bug :(

But in a megamod, so prolly not the fault of SCSII :)

I thought I should let you know anyway. I have reported the problem here http://www.shsforums...post__p__532898 .

The debug can be downloaded from there also.

Lastly... I think you are absolutely the bee's knees!

May your spells never fail!

#17 DavidW

DavidW
  • Gibberlings
  • 4158 posts
  • Gender:Male

Posted 25 January 2012 - 09:44 AM

Known compatibility problem. Edit scsii/scsii.ini with Notepad or similar. The second time you see "Mage_Ignore_SR", change it to "Priest_Ignore_SR". (I haven't had a chance to upload a fix.)

Edited by DavidW, 25 January 2012 - 09:45 AM.


#18 Anduin Shadow Mantle

Anduin Shadow Mantle
  • Members
  • 3 posts

Posted 26 January 2012 - 05:33 AM

So basically my scsii.ini should look like this...

Mage_Level_No_Adjustments 0
Mage_Level_Add 0
Mage_Level_Scale 100
Mage_Ignore_SR 0
Priest_Level_No_Adjustments 0
Priest_Level_Add 0
Priest_Level_Scale 100
Priest_Ignore_SR 0
Sendai_Component_Is_Sendai_Only 0
AI_Does_Not_Detect_Items 0
Conceal_Prebuff_Spell_Names 0
Force_No_HLA_Repeats 0
Disable_SSL_Compilation 0
Disable_ToBEx 0

Cool gonna try a new megamod install tonight. Will let you know the results. :D

#19 Anduin Shadow Mantle

Anduin Shadow Mantle
  • Members
  • 3 posts

Posted 29 January 2012 - 09:32 AM

Solved! Thank you...

May I add super fast response too!

#20 DavidW

DavidW
  • Gibberlings
  • 4158 posts
  • Gender:Male

Posted 29 January 2012 - 02:57 PM

Glad to hear it. (I need to get around to updating to fix this.)

#21 phuongww11

phuongww11
  • Members
  • 1 posts

Posted 31 January 2012 - 03:28 PM

Hi, I use the new quick install.
I chose for

Decrease the rate at which reputation improves -> Reputation increases at about 1/3 the normal rate: v20
Add high-level abilities (HLAs) to ToB mages -> Only selected ToB mages get HLAs: v20
Add high-level abilities (HLAs) to ToB priests -> Only selected ToB priests get HLAs: v20

but instead I got

Decrease the rate at which reputation improves -> Reputation increases at about 1/2 the normal rate: v20
Add high-level abilities (HLAs) to SoA mages -> Only selected SoA mages get HLAs: v20
Add high-level abilities (HLAs) to SoA priests -> Only selected SoA priests get HLAs: v20

Everything else install correctly.

I read that you are open for suggestions about more choices for the quick install.
I on the other hand would like to request an complete quick install without any choices.
That kind of standard/reference could be nice for ppl like me (maybe only minority from those playing with mods) who are not into reading wall of meta information before playing, who like discovery, surprises and beating challenges that they didnt made up themself. :)

#22 DavidW

DavidW
  • Gibberlings
  • 4158 posts
  • Gender:Male

Posted 01 February 2012 - 08:27 AM

Thanks, that's the first feedback I've had on how it works. There're probably a couple of typos causing the problem you've found; I'll sort it out for the next release.

I can probably do something like what you're asking for - though I'd want to make sure I don't then get blamed for making the game too hard. (I'm generally keen that people read the SCS readme so they know roughly what they're letting themselves in for.)

#23 Dakk

Dakk
  • Members
  • 824 posts
  • Gender:Male

Posted 03 February 2012 - 05:55 PM

SCSII component Move Boo into Minsc's pack does not detect the component Move Boo out of quick access and into Minsc's pack from SCS; which I suppose it should?

Very minor, and I can't imagine installing both components will have any adverse effects :)

Edited by Dakk, 03 February 2012 - 05:57 PM.


#24 jastey

jastey
  • Gibberlings
  • 5473 posts
  • Gender:Female

Posted 10 February 2012 - 01:13 PM

Someone assumes that SCSII lead to some weird game behaviour here at SHS in case you haven't seen this.

#25 polytope

polytope
  • Members
  • 273 posts
  • Gender:Male

Posted 11 February 2012 - 02:49 AM

Someone assumes that SCSII lead to some weird game behaviour here at SHS in case you haven't seen this.


I'm pretty sure that's a graphical glitch caused by an older version of ToBEx - if they're referring to the black boxes around shair.bam and magic missiles.
Polytweak - Polytope's enhancements of BG2 creatures, NPCs and the proficiency system.

#26 ussnorway

ussnorway
  • Members
  • 6 posts
  • Gender:Female

Posted 26 February 2012 - 11:11 PM

Posted Image Posted Image

There is a bug in;
~SCSII/SETUP-SCSII.TP2~ #0 #1000 // Initialise mod (all other components require this): v20

When installed on a fresh BG2 (GoG version) It causes the ‘Chain Contingently’ spell to misreport the targeting info... doesn’t matter if you put ‘Spell Immunity’ in the chain or even if you don’t actually know the spell.

#27 Ba'alzamon

Ba'alzamon
  • Members
  • 14 posts

Posted 01 March 2012 - 04:38 PM

I decided to change some things in my install-in-progress and removed scsii per component. But I ran into this problem and now it's probably best to start completely fresh all over again. But fyi I'm posting it here.

(After uninstalling main required scsii component) Cannot uninstall following components:
Improved fiends, Smarter genies, Smarter celestials, Smarter dragons, Add HLAs to ToB mages.
Choosing the uninstall option simply loops back as if I typed an invalid key. Other components inbetween these uninstalled fine. I think there are more uninstallable components after that since there'a bit of a pattern to them, but I quit before trying them all. Thinking it was because of missing main component, I reinstalled it and tried uninstalling everything again, but it acted as if those components were not installed anymore. I'm sure they're still there, just not "on record".

Additionally, before doing this I had gone over my installs again and found that choosing "No change" didn't skip already installed components, but rather reinstalled them even though that was not what I selected. This seems to happen with the installers of a lot of other mods too. Not sure if it's a install script thing or a WeiDU thing.

Maybe these aren't bugs at all but rather some mistake of mine, or not enough for you to worry about since they don't occur if you plan and execute installation correctly. I'm opting to scrap the whole thing and start over. But thought I'd point it out.

#28 Galefury

Galefury
  • Members
  • 7 posts

Posted 05 March 2012 - 01:01 PM

I cant install "More sensible choices of weapon proficiencies and kits for fighters". Something about an illegal read. Full error message below, .debug and weidu.log attached (extension changed so I can attach them). I do have a bunch of other mods installed. There also was an error about the autoinstaller when I first tried to install SCS2, but I didn't use it, so no idea if that matters.

ERROR: illegal 4-byte read from offset -1 of 1540-byte file M#YCLBM1.CRE
ERROR: [M#YCLBM1.CRE] -> [override/M#YCLBM1.CRE] Patching Failed (COPY) (Failure
("M#YCLBM1.CRE: read out of bounds"))
Stopping installation because of error.
Stopping installation because of error.
ERROR Installing [More sensible choices of weapon proficiencies and kits for fig
hters (also fixes some errors in fighter stats)], rolling back to previous state
Will uninstall 596 files for [SCSII/SETUP-SCSII.TP2] component 6015.
Uninstalled	596 files for [SCSII/SETUP-SCSII.TP2] component 6015.
ERROR: Failure("M#YCLBM1.CRE: read out of bounds")
PLEASE email the file SETUP-SCSII.DEBUG to davidw, Gibberlings3 forums
Using Language [English]

Attached Files



#29 galious

galious
  • Members
  • 1 posts

Posted 13 March 2012 - 07:59 PM

Hi!

Long time lurker, first time poster here.
I recently dug up my old BG2 discs again and have been thoroughly enjoying this oldie but goodie, especially with SCSii breathing new life into it. Great job here!

It's worked almost flawlessly through the first 6 chapters but it's sadly been crashing a lot these last couple of nights. :(

The game crashes and I get an error message that reads:
"An Assertion Failed in ChVidImage.cpp at line number 1910"

The TobEX:Tob box reads:
"Assertion Failed! Returned Address: 0 x 9CCAD1
File:ChVidImage.cpp Line: 1910 Expression: ! <cdwFlags & CVIDIMG_TRANSLUCENT> & <dwFlags & CVIDCELL_BRIGHTEST>> Message: <null>

This first happened during the Twisted Rune fight and I had to reload the fight about 5-6 times before I could complete it without a crash. The second instance was while clearing Bodhi's lair (chapter 6). I had no crashes in chapters 1-3 at all, and the only difference I can think of is that I enabled the Improved Vampires and Improved Bodhi's lair components after this. I did some searching online for solutions and found that the same thing was reported back in version 18 by user "ilot": http://forums.gibber...pic=22098&st=30

Sadly, the only solution that was suggested was to uninstall the improved vampires component, which would be a shame because the regular, unmodded vampires are so boring!

I am running BG2 / ToB with the official patch, G3 fixpack, G3 tweakpack, G3 Unfinished Business, Kelsey, Saerileth, Widescreen Mod and SCSii (v. 20)

Any suggestions would be greatly appreciated.
Thanks!

#30 Shaitan

Shaitan

    Bad bad nurse.

  • Members
  • 1577 posts
  • Gender:Male
  • Location:Copenhagen, Denmark

Posted 16 March 2012 - 12:57 AM

Hi

Quiet confident this has been reported before. Hagan fires his speech and does nothing more.

Hope you'll be able to look into this.

Cheers and thanks in advance
"You're dumb as a mule and twice as ugly. If a strange man offers you a ride I say take It"
-Grandpa Simpson



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users