Jump to content

Problem making overlays

5 replies to this topic

#1 Guest_Guest_*

  • Guests

Posted 01 March 2011 - 12:28 PM

I tried following Yovaneth's tutorial on area making, and ran into a snag.

It was in making overlays. I created the polygon using the bottom third of the Edit WED screen and it seemed to be fine. Click on floodfill and it showed the area I wanted to become overlay. Back, then load an existing TIS. Initially, I was using WTSEWER, but since then I've tried a fair share of the WT overlays, all with the same result. That being that when I click "Make Overlay" and go back with "View All", "Edit Tiles" then scroll to the area, the overlay tiles have been put in only for the border of the polygon. Which is fine for narrow overlays, but when the overlay gets larger than 2 tiles, it leaves the interior un-overlayed, if that's a word.

I can replace those tiles manually, sure, but for larger areas that gets almost as tedious as making a search map. Might I have some setting wrong somewhere, or what? Looking at Yovaneth's screenshots, some areas look larger than two tiles, so that must be the case, but I can't find it anywhere.

Any hints?


#2 Avenger

  • Modders
  • 3428 posts
  • Gender:Male
  • Location:Hungary

Posted 01 March 2011 - 11:00 PM

When you say larger than 2 tiles, i guess it means, DLTCEP needs to add some tiles that don't have a stencil mask. IE: the whole tile is covered by the overlay?

It could be, that I've never tested such cases. I'll check this when i get to it.

Have you tested this in the game too? It might work there, i think there were cases when DLTCEP couldn't render the interior tiles correctly.

Edited by Avenger, 01 March 2011 - 11:01 PM.

#3 Guest_Guest_*

  • Guests

Posted 02 March 2011 - 11:06 PM

Sorry. Picture. Words.

Posted Image

Maybe I'm trying to do something that an overlay isn't supposed to do. I figured if I used an overlay which was not transparent, with the right search map, it would look as if the ARE tileset had the graphic in it. If that's not the case I guess I'm not understanding how the engine handles overlays.

Anyway, thanks, and sorry for the confusion.

#4 Avenger

  • Modders
  • 3428 posts
  • Gender:Male
  • Location:Hungary

Posted 02 March 2011 - 11:11 PM

No, you do everything alright, I just asked if you actually seen the freshly made overlay (without you additionally doing anything to it), in the game.
DLTCEP may be wrong with the display.

#5 Guest_Guest_*

  • Guests

Posted 02 March 2011 - 11:32 PM

Oh, I understand. No, I didn't check it yet in the game. I don't have CD6 with me so I'll have to check it tomorrow.


#6 Yovaneth

  • Members
  • 210 posts
  • Gender:Male
  • Location:The Kingdom of Mourne

Posted 15 March 2011 - 03:13 AM

DLTCEP has displayed it like that for a long time. The 'floodfill' feature only works while you're laying out the polygon; once you've created the overlay the in-DLTCEP display only shows the boundaries. Now you draw my attention to it, it's been like that for a while. There was a time when the overlay interior did show a single overlay tile (the first one?).


Edited by Yovaneth, 15 March 2011 - 03:22 AM.

Reply to this topic


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users