Jump to content


Photo

Post-Spellhold Brynnlaw Bug


21 replies to this topic

#16 Guest_guest_*

Guest_guest_*
  • Guests

Posted 09 September 2009 - 05:37 PM

I found another thread saying that this happened when a save was made before Saemon had enough time to leave the tavern, and I'm pretty sure that would have been the case in my game.

How sure are you? The game is supposed to prevent you from saving when actions like these are performed. In this case, you should be unable to save until Saemon has left the tavern.


This is just a general sort of reply to saving in such a situation: I find it's quite possible to save in many situations you shouldn't be allowed to if you're either quick enough, or if there's a small amount of lag, or (in the case of combat) enemies temporarily go out of view as they chase you or something. Just a few cases that come to mind straight away - any combination of these and other circumstances can allow you to save when you "should be unable to". I'm sure this is nothing new that i'm uncovering though.

The real point is that you don't have to be actively trying to catch the game out and save in such a manner, it's quite easy to do this at least once or twice per game (considering bg is a long game) even when you're experienced with mechanics, nuances, and general behaviours and plot related actions that occur throughout the game, let alone if you're new and want to save before anything you deem "important", "just in case".

#17 bowbow99

bowbow99
  • Members
  • 6 posts

Posted 14 October 2010 - 02:58 AM

Hi, folks. I also had this problem, and setting resolution to 800x600 solved it for me.

Since I encounter this problem everytime I make a installation of BG2 and play, I knew this problem can be sovled by create him near the ship via console but didn't remember exact command, so I googled a bit and found this thread. From what posted here, I found that where thing go wrong is how Saemon go away when you accept his proposal in Vulgar Monkey inn. This reminded me another problem which I suspect they share same cause: high resolution.
I had a little test: in 1680x1050 (thanks to widescreen-mod), Saemon just disappear. When I uninstall widescreen-mod and set resolution to 800x600 or 1024x768, he walk to exit as expected. So resolution affecting how Saemon behave in my installation.

Following is just a suspicion I have, and since I'm not a skilled modder nor an IE hacker it could be wrong.
The suspicion I have is that game engine fail to calculate screen/position relation ("Offscreen" thing) if it running in high resolution and misbehave. As a result, Saemon disappear instead of walk to exit, in this case.
I also suspect the problem in a cut-scene of Kruin (this seems also common problem. http://www.shsforums...ene-with-kruin/ for instance.) and ekresspy of FP+PS (I reported in forum http://forums.gibber...showtopic=18767 ) are also result of this misbehavior of game engine.

I don't know what can be done to deal with this other than set resolution or get rid of these misbehaving script commands though.

#18 Guest_Saemon's Guest_*

Guest_Saemon's Guest_*
  • Guests

Posted 16 October 2010 - 01:58 AM

To those investigating this bug, I thought I'd add my two cents.

I'm having the exact same (reproducible) bug as the original poster. I too am playing BG2 on the latest patch, using the G3 fix pack, tweak pack, and widescreen mod. And, like the other posters, Saemon disappears after talking to me in the Vulgar Monkey after escaping Spellhold. It should be noted that I also chose to use the Wardstone to enter Spellhold.

The last poster in this thread mentioned that he believed the increased resolution of the widescreen mod to be the issue. Given a tiny amount of testing, this seems to be the case. I simply saved in the VM before talking to Saemon, uninstalled the WS mod, and loaded my game. Saemon, instead of disappearing, walked out the door and took his place by the docks. After this, I saved and reinstalled the WS mod, and he stayed right where he was supposed to be. If it's relevant, I'm using 1680x1050 as my resolution.

tldr; uninstall the widescreen mod and Saemon will behave properly

#19 Guest_Gestur_*

Guest_Gestur_*
  • Guests

Posted 22 June 2011 - 02:30 PM

another 2ยข,
My conf:
SOA+TOB latest patch, G3 fix pack (v9), tweak pack (v9), aTweaks (3.54) and widescreen mod (3.04). Same issue - uninstalled the widescreen mod, and Saemon behaved correctly for me as well. Thanks to bowbow99 for suggesting this.

#20 Guest_Kevin_*

Guest_Kevin_*
  • Guests

Posted 13 October 2011 - 01:15 AM

Okay, I know this is a buried thread but I think I can help to deduce what is causing the bug, if anyone is still working on it or even cares anymore. Lol. I encounter the same bug where as soon as I accept the quest from Saemon he vanishes into thin air and is nowhere to be found. However, unlike the other people in this thread who encountered the bug, I am not running any tweak packs or fix packs or anything like that. The only mod I am running is the widescreen mod. So the bug must related to the widescreen patches somehow. To make this even more frustrating, I simply cannot get my clua console to enable. I have spent hours in the .ini file adding and removing both debug mode=1 under program settings and cheats=1 under game settings but no matter how many times, where I install the game, how i edit and save the file, how i add the commands, or how I do anything the game doesn't seem to read the script. it's very frustrating that i cannot continue to that chapter and I have to skip to the under dark. maybe somebody can help me? Lol and sorry for bumping up a dead thread. :0

#21 Guest_Kevin_*

Guest_Kevin_*
  • Guests

Posted 13 October 2011 - 01:21 AM

Okay, I know this is a buried thread but I think I can help to deduce what is causing the bug, if anyone is still working on it or even cares anymore. Lol. I encounter the same bug where as soon as I accept the quest from Saemon he vanishes into thin air and is nowhere to be found. However, unlike the other people in this thread who encountered the bug, I am not running any tweak packs or fix packs or anything like that. The only mod I am running is the widescreen mod. So the bug must related to the widescreen patches somehow. To make this even more frustrating, I simply cannot get my clua console to enable. I have spent hours in the .ini file adding and removing both debug mode=1 under program settings and cheats=1 under game settings but no matter how many times, where I install the game, how i edit and save the file, how i add the commands, or how I do anything the game doesn't seem to read the script. it's very frustrating that i cannot continue to that chapter and I have to skip to the under dark. maybe somebody can help me? Lol and sorry for bumping up a dead thread. :0


Somehow I missed all the recent posts of people explaining that it was the widescreen mod. LOL. Well yeah, It's the widescreen mod and somebody who knows what they're doing should patch it!

#22 Isaya

Isaya
  • Members
  • 139 posts
  • Gender:Male
  • Location:Plaisir, France

Posted 16 October 2011 - 12:53 AM

Your problems to activate the console make me think you're running Windows Vista or 7, and you installed the game in the default directory, or at least in the "Program Files" of your system disk. This is known to cause issues when trying to use the console, and also when playing with mods.

For details, you can read this. Vista and 7 behave the same regarding the protection of the "Program Files" (typically displayed only as "Programs" in the Windows Explorer).

Besides, if you read explainations by bowbow99, this is nothing that can be fixed in the Widescreen mod. It seems the bug is from the game engine itself and only highlighted when the resolution is high.



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users