Jump to content


Upgraded, still can't place 3 *s in most thief kits


2 replies to this topic

#1 Guest_Irked_*

Guest_Irked_*
  • Guests

Posted 05 August 2009 - 01:46 PM

Assassin and bounty hunter, one star only. Vanilla thief, one star only.

Dirgesingers are still stuck to leather armor, acrobats still have certain magical scrolls redded out like they were an opposition school, (but can still use them) and it doesn't seem like anything was actually fixed from the last version.

Kind of annoying.

#2 cmorgan

cmorgan

    journeyman investigator

  • Gibberlings
  • 6913 posts
  • Gender:Male
  • Location:Glencoe, IL, USA

Posted 06 August 2009 - 07:19 AM

Not sure what us going on in your game with vanilla thief/assassin/bountyhunter - please check your .2da for the following:

170,177c170,186
<   PATCH_FOR_EACH kit IN 7 16 18 39 40 41 BEGIN
<	 SET_2DA_ENTRY_LATER set 34 kit 3
<   END
<   SET_2DA_ENTRY_LATER set 16 41 2 //Swashbucklers, katanas
<   SET_2DA_ENTRY_LATER set 26 41 1 //Swashbucklers, crossbows
<   SET_2DA_ENTRY_LATER set 28 41 1 //Swashbucklers, short bows
<   SET_2DA_ENTRY_LATER set 30 41 1 //Swashbucklers, slings
<   SET_2DA_ENTRIES_NOW set 1
---
>   COUNT_2DA_COLS cols
>   // 3 points in dual-wielding for thieves
>   SET_2DA_ENTRY_LATER weapprof 31 7  ~3~ // Thief
>   SET_2DA_ENTRY_LATER weapprof 31 14 ~3~ // Fighter/Thief (just in case)
>   SET_2DA_ENTRY_LATER weapprof 31 15 ~3~ // Fighter/Mage/Thief (just in case)
>   SET_2DA_ENTRY_LATER weapprof 31 16 ~3~ // Mage/Thief
>   SET_2DA_ENTRY_LATER weapprof 31 18 ~3~ // Cleric/Thief
>   SET_2DA_ENTRY_LATER weapprof 31 39 ~3~ // Assassin
>   SET_2DA_ENTRY_LATER weapprof 31 40 ~3~ // Bounty Hunter
>   SET_2DA_ENTRY_LATER weapprof 31 41 ~3~ // Swashbuckler
>  
>   // fix swashbuckler profs
>   SET_2DA_ENTRY_LATER weapprof 13 41 ~2~ // Swashbucklers, katanas
>   SET_2DA_ENTRY_LATER weapprof 23 41 ~1~ // Swashbucklers, crossbows
>   SET_2DA_ENTRY_LATER weapprof 25 41 ~1~ // Swashbucklers, short bows
>   SET_2DA_ENTRY_LATER weapprof 27 41 ~1~ // Swashbucklers, slings
>   SET_2DA_ENTRIES_NOW weapprof cols

becasue it sounds like either another mod has re-editied the profs or something has failed i can confirm that these changes apply on my game).

Readme does not indicate Dirgesingers are allowed additional armor - I don't see anything in the code that chnages that, bt perhaps I missed it - if it is written somewhere in the mod explicitly, then perhaps someone could code up a change, but since this is maintenence for Andyr, without direct reference it is not something to change. SK is your friend.

On the acrobat scrolls/opposing schools thing, someone with better skills than me will have to takle a look, but if it is cosmetic, at least it doesn't stop gameplay.

Please post a weidu.log and some supporting details, so folks can help you out - especially a changed .2da to see if something else is messing with it before or after S&S so that we can see if the correct columns are being modded on your game.
I love deadlines. I love the whooshing noise they make as they go by. - Douglas Adams

#3 Mike1072

Mike1072
  • Gibberlings
  • 1771 posts
  • Gender:Male
  • Location:Canada

Posted 06 August 2009 - 07:30 PM

Assassin and bounty hunter, one star only. Vanilla thief, one star only.

This should not be happening in v4. As cmorgan said, your WeiDU.log would be helpful in tracking this down.

Dirgesingers are still stuck to leather armor

I wasn't aware of this problem before, thanks for reporting it. The description mentions nothing of this being a disadvantage of the kit, so it seems to be a bug. This applies to Choristers as well. Their usability entries should be changed from 0x00010000 to 0x00004000 on lines 473 and 566 of the .tp2.

acrobats still have certain magical scrolls redded out like they were an opposition school

Are you referring to Stoneskin and Fireshield (Blue)? This is due to the vanilla items having flags strangely set to make them unusable by certain kits. S&S happens to borrow one of those kits (in this case, the stalker) to restrict acrobats from wearing armour greater than studded leather. A fix will be to make these items (scrl1w.itm, scrl2b.itm, and also potn56.itm) usable by stalkers, which won't have any effect on stalkers but will allow acrobats to use the scrolls and the Rogue's Potion of Frost Giant Strength.

Edited by Mike1072, 09 August 2009 - 05:04 PM.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users